RebarShapeDefinitionBySegmentsRemoveParameterFromSegment Method |
Remove constraints from a segment.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveParameterFromSegment(
int iSegment,
ElementId paramId
)
Public Sub RemoveParameterFromSegment (
iSegment As Integer,
paramId As ElementId
)
public:
void RemoveParameterFromSegment(
int iSegment,
ElementId^ paramId
)
member RemoveParameterFromSegment :
iSegment : int *
paramId : ElementId -> unit
Parameters
- iSegment Int32
-
Index of the segment (0 to NumberOfSegments - 1).
- paramId ElementId
-
Id of a parameter driving one or more constraints.
ExceptionsException | Condition |
---|
ArgumentException |
iSegment is not between 0 and NumberOfSegments.
-or-
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.
See Also