ContourSettingAddContourRange Method |
Add a set of contours as a contour setting item to the current contour setting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ContourSettingItem AddContourRange(
double start,
double stop,
double step,
ElementId subcategoryId
)
Public Function AddContourRange (
start As Double,
stop As Double,
step As Double,
subcategoryId As ElementId
) As ContourSettingItem
public:
ContourSettingItem^ AddContourRange(
double start,
double stop,
double step,
ElementId^ subcategoryId
)
member AddContourRange :
start : float *
stop : float *
step : float *
subcategoryId : ElementId -> ContourSettingItem
Parameters
- start Double
-
The contour range start elevation.
- stop Double
-
The contour range stop elevation.
Should be greater than start elevation.
- step Double
-
The increment elevation of the contour range.
Should be greater than zero.
- subcategoryId ElementId
-
The contour line style subcategory id.
Return Value
ContourSettingItem
The newly added contour setting item.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for start is not finite
-or-
The given value for stop is not finite
-or-
The given value for step is not finite
-or-
The input subcategory id is not valid.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The input contour spacing information is not valid.
|
See Also