DirectShapeSetTypeId Method |
Sets the DirectShapeType for the DirectShape element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetTypeId(
ElementId typeId
)
Public Sub SetTypeId (
typeId As ElementId
)
public:
void SetTypeId(
ElementId^ typeId
)
member SetTypeId :
typeId : ElementId -> unit
Parameters
- typeId ElementId
-
The ID of the type corresponding to this DirectShape element. May only be set once.
Exceptions
See Also