ExporterIFCUtilsGetInstanceCutoutFromWall Method |
Gets the curve loop corresponding to the hole in the wall made by the instance.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static CurveLoop GetInstanceCutoutFromWall(
Document pADoc,
Wall pVWall,
FamilyInstance pFamInst,
out XYZ pCutDir
)
Public Shared Function GetInstanceCutoutFromWall (
pADoc As Document,
pVWall As Wall,
pFamInst As FamilyInstance,
<OutAttribute> ByRef pCutDir As XYZ
) As CurveLoop
public:
static CurveLoop^ GetInstanceCutoutFromWall(
Document^ pADoc,
Wall^ pVWall,
FamilyInstance^ pFamInst,
[OutAttribute] XYZ^% pCutDir
)
static member GetInstanceCutoutFromWall :
pADoc : Document *
pVWall : Wall *
pFamInst : FamilyInstance *
pCutDir : XYZ byref -> CurveLoop
Parameters
- pADoc Document
-
The document.
- pVWall Wall
-
The host wall.
- pFamInst FamilyInstance
-
The hosted instance.
- pCutDir XYZ
-
The direction of the hole relative to the location of the curve loop.
Return Value
CurveLoop
The opening in the wall.
Exceptions
See Also