Removes a filter from the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveFilter(
ElementId filterElementId
)
Public Sub RemoveFilter (
filterElementId As ElementId
)
public:
void RemoveFilter(
ElementId^ filterElementId
)
member RemoveFilter :
filterElementId : ElementId -> unit
Parameters
- filterElementId ElementId
-
ElementId of the filter.
ExceptionsException | Condition |
---|
ArgumentException |
Filter is not applied to the view.
-or-
ElementId is not associated with a FilterElement.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
See Also