PathReinforcementPrimaryBarShapeId Property |
The RebarShape element that defines the shape of the primary bars of the Path Reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId PrimaryBarShapeId { get; set; }
Public Property PrimaryBarShapeId As ElementId
Get
Set
public:
property ElementId^ PrimaryBarShapeId {
ElementId^ get ();
void set (ElementId^ value);
}
member PrimaryBarShapeId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: shapeId should refer to two dimensional Rebar Shape element with segments forming only right angles.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
When setting this property: This PathReinforcement does not host Rebar.
|
Remarks
Changing the value of this property causes the Path Reinforcement to choose values for its
shape parameters.
See Also