DocumentNewOpening(Wall, XYZ, XYZ) Method |
Creates a rectangular opening on a wall.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Opening NewOpening(
Wall wall,
XYZ pntStart,
XYZ pntEnd
)
Public Function NewOpening (
wall As Wall,
pntStart As XYZ,
pntEnd As XYZ
) As Opening
public:
Opening^ NewOpening(
Wall^ wall,
XYZ^ pntStart,
XYZ^ pntEnd
)
member NewOpening :
wall : Wall *
pntStart : XYZ *
pntEnd : XYZ -> Opening
Parameters
- wall Wall
- Host element of the opening.
- pntStart XYZ
- One corner of the rectangle.
- pntEnd XYZ
- The opposite corner of the rectangle.
Return Value
Opening If successful, an Opening object is returned.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the wall
does not exist in the given document, or if the wall doesn't support
rectangular openings. |
RemarksSlanted stacked walls do not support rectangular openings.
See Also