ViewGetIsFilterEnabled Method |
Identifies if the filter is enabled in this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool GetIsFilterEnabled(
ElementId filterElementId
)
Public Function GetIsFilterEnabled (
filterElementId As ElementId
) As Boolean
public:
bool GetIsFilterEnabled(
ElementId^ filterElementId
)
member GetIsFilterEnabled :
filterElementId : ElementId -> bool
Parameters
- filterElementId ElementId
-
The ElementId of the filter.
Return Value
Boolean
True if the specified filter is enabled in this view, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
Filter is not applied to the view.
-or-
ElementId is not associated with a FilterElement.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
Remarks
Several filters can be applied to a view in a certain order. This enable/disable flag
allows one to quickly turn on/off the action of a particular filter in this view (without
removing the filter from the set of applied filters and losing the corresponding overrides).
By default, all the filters applied to a view are enabled.
See Also