FilteredElementIteratorGetCurrent Method |
The current element found by the iterator.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Element GetCurrent()
Public Function GetCurrent As Element
public:
Element^ GetCurrent()
member GetCurrent : unit -> Element
Return Value
Element
The element.
ExceptionsException | Condition |
---|
InvalidOperationException |
There are no more element ids in the iterator.
-or-
The FilteredElementCollector that yielded this iterator has been reset by another operation.
No further iteration is permitted with this iterator.
-or-
The iterator cannot proceed due to changes made to the Element table in Revit's database (typically,
This can be the result of an Element deletion).
|
See Also