Add segments to the gutter.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic override void AddSegment(
Reference targetRef
)
Public Overrides Sub AddSegment (
targetRef As Reference
)
public:
virtual void AddSegment(
Reference^ targetRef
) override
abstract AddSegment :
targetRef : Reference -> unit
override AddSegment :
targetRef : Reference -> unit
Parameters
- targetRef Reference
- Segment's reference on which want to be added.
ExceptionsException | Condition |
---|
ArgumentNullException |
This exception will be thrown in following cases:
1. Input targetRef is null.
2. Input targetRef is not null but contains nothing.
|
InvalidOperationException |
This exception will be thrown in following cases:
1. Input targetRef has already been added into the gutter.
2. Internal code fails to create the segment object.
3. Regeneration fails.
|
ArgumentOutOfRangeException |
This exception will be thrown if the reference is not suitable for creating a gutter as required.
The reference allowed is :
1. Model Line
2. Roof's horizontal edges
3. Soffit's horizontal edges
4. Fascia's horizontal edges
|
See Also