ExporterIFCUtilsAreSolidsEqual Method |
Determines whether two solids are identical, potentially offset from each other.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool AreSolidsEqual(
Solid first,
Solid second,
out Transform trf
)
Public Shared Function AreSolidsEqual (
first As Solid,
second As Solid,
<OutAttribute> ByRef trf As Transform
) As Boolean
public:
static bool AreSolidsEqual(
Solid^ first,
Solid^ second,
[OutAttribute] Transform^% trf
)
static member AreSolidsEqual :
first : Solid *
second : Solid *
trf : Transform byref -> bool
Parameters
- first Solid
-
The first solid.
- second Solid
-
The second solid
- trf Transform
-
The offset transform
Return Value
Boolean
True if they are identical, false otherwise.
Exceptions
See Also