RebarSpliceTypeUtilsSetShiftOption Method |
Sets the way bars are shifted in the splice relation.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetShiftOption(
Document document,
ElementId rebarSpliceTypeId,
RebarSpliceShiftOption shiftOption
)
Public Shared Sub SetShiftOption (
document As Document,
rebarSpliceTypeId As ElementId,
shiftOption As RebarSpliceShiftOption
)
public:
static void SetShiftOption(
Document^ document,
ElementId^ rebarSpliceTypeId,
RebarSpliceShiftOption shiftOption
)
static member SetShiftOption :
document : Document *
rebarSpliceTypeId : ElementId *
shiftOption : RebarSpliceShiftOption -> unit
Parameters
- document Document
-
The document.
- rebarSpliceTypeId ElementId
-
The Rebar Splice Type id.
- shiftOption RebarSpliceShiftOption
-
The way bars are shifted in the splice relation.
ExceptionsException | Condition |
---|
ArgumentException |
The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also