MeshTriangle Class

One triangle of a mesh.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBMeshTriangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MeshTriangle

The MeshTriangle type exposes the following members.

Properties
 NameDescription
Public propertyIndexThe index of the vertex in the Vertices array of the mesh, for indexed access.
Public propertyVertexA vertex of the triangle.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also