ZoneEquipmentMoveSpaceToEquipment Method |
Moves the selected analytical spaces from the identified zone equipment to another target zone equipment.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void MoveSpaceToEquipment(
Document document,
ISet<ElementId> analyticalSpaceSet,
ElementId originalZoneEquipmentId,
ElementId targetZoneEquipmentId
)
Public Shared Sub MoveSpaceToEquipment (
document As Document,
analyticalSpaceSet As ISet(Of ElementId),
originalZoneEquipmentId As ElementId,
targetZoneEquipmentId As ElementId
)
public:
static void MoveSpaceToEquipment(
Document^ document,
ISet<ElementId^>^ analyticalSpaceSet,
ElementId^ originalZoneEquipmentId,
ElementId^ targetZoneEquipmentId
)
static member MoveSpaceToEquipment :
document : Document *
analyticalSpaceSet : ISet<ElementId> *
originalZoneEquipmentId : ElementId *
targetZoneEquipmentId : ElementId -> unit
Parameters
- document Document
-
The document where the zone equipment and the analytical spaces exist.
- analyticalSpaceSet ISetElementId
-
The specified analytical spaces to move.
- originalZoneEquipmentId ElementId
-
The original equipment where the analytical spaces will be removed. If passing invalidElementId, the existing zone equipment is not removed.
- targetZoneEquipmentId ElementId
-
The target zone equipment where the analytical spaces will be associated. If passing invalidElementId, the analytical spaces will not be assigned to any new zone equipment.
Exceptions
See Also