ExporterIFCUtilsSetGlobal3DDirectionHandles Method |
Sets the handles representing the cardinal directions in 3D.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetGlobal3DDirectionHandles(
bool positive,
IFCAnyHandle xDir,
IFCAnyHandle yDir,
IFCAnyHandle zDir
)
Public Shared Sub SetGlobal3DDirectionHandles (
positive As Boolean,
xDir As IFCAnyHandle,
yDir As IFCAnyHandle,
zDir As IFCAnyHandle
)
public:
static void SetGlobal3DDirectionHandles(
bool positive,
IFCAnyHandle^ xDir,
IFCAnyHandle^ yDir,
IFCAnyHandle^ zDir
)
static member SetGlobal3DDirectionHandles :
positive : bool *
xDir : IFCAnyHandle *
yDir : IFCAnyHandle *
zDir : IFCAnyHandle -> unit
Parameters
- positive Boolean
-
True if the handles returned should be in the positive direction, false
if the handles should be in the negative direction.
- xDir IFCAnyHandle
-
The X direction handle.
- yDir IFCAnyHandle
-
The Y direction handle.
- zDir IFCAnyHandle
-
The Z direction handle.
Exceptions
See Also