Checks whether a field can be used with a value presence-based filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public bool CanFilterByValuePresence( ScheduleFieldId fieldId ) |
Visual Basic |
---|
Public Function CanFilterByValuePresence ( _ fieldId As ScheduleFieldId _ ) As Boolean |
Visual C++ |
---|
public: bool CanFilterByValuePresence( ScheduleFieldId^ fieldId ) |
Parameters
- fieldId
- Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used with a value presence filter, false otherwise.
Remarks
The value presence filter types are HasValue and HasNoValue.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |