Gets a copy of the font info associated to the input font key.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ExportFontInfo GetExportFontInfo( ExportFontKey exportFontKey ) |
Visual Basic |
---|
Public Function GetExportFontInfo ( _ exportFontKey As ExportFontKey _ ) As ExportFontInfo |
Visual C++ |
---|
public: ExportFontInfo^ GetExportFontInfo( ExportFontKey^ exportFontKey ) |
Parameters
- exportFontKey
- Type: Autodesk.Revit.DB..::..ExportFontKey
The export font Key.
Return Value
Returns the fontInfo for this key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |