Returns one point at the given index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public XYZ GetPoint( int idx ) |
Visual Basic |
---|
Public Function GetPoint ( _ idx As Integer _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetPoint( int idx ) |
Parameters
- idx
- Type: System..::..Int32
A zero-based index of a polymesh point
Return Value
XYZ coordinates of the point
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given value is not a valid index of a point of the polymesh. A valid valure is not negative and is smaller than the number of points in the polymesh. |