A class representing topology of a polymesh.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public class PolymeshTopology : IDisposable |
Visual Basic |
---|
Public Class PolymeshTopology _ Implements IDisposable |
Visual C++ |
---|
public ref class PolymeshTopology : IDisposable |
Remarks
Topology of a polymesh consists of a number of points and triangular facets formed
by the points. Each facet is determined by three indices to the array of points.
A polymesh may have UV coordinates assigned, and always has at least one normal associated.
There may be more than one normal available for a non-planar polymesh; there may be as many
normals as there are either facets or points in the polymesh. The DistributionOfNormals
property indicates how normals are distributed along the polymesh.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..PolymeshTopology
Autodesk.Revit.DB..::..PolymeshTopology