Creates a new EndTreatmentType object with a default name.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static ElementId CreateDefaultEndTreatmentType( Document ADoc ) |
Visual Basic |
---|
Public Shared Function CreateDefaultEndTreatmentType ( _ ADoc As Document _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ CreateDefaultEndTreatmentType( Document^ ADoc ) |
Parameters
- ADoc
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
The newly created type id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |