Creates a floor within the project with the given horizontal profile using the default floor style.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Floor NewFloor( CurveArray profile, bool structural ) |
Visual Basic |
---|
Public Function NewFloor ( _ profile As CurveArray, _ structural As Boolean _ ) As Floor |
Visual C++ |
---|
public: Floor^ NewFloor( CurveArray^ profile, bool structural ) |
Parameters
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
- structural
- Type: System..::..Boolean
If set, specifies that the floor is structural in nature.
Return Value
If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Remarks
The curves of the profile must be contiguous and
the Face formed by profile should be suitable to create floor.