Creates an array of new detail curve elements.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public DetailCurveArray NewDetailCurveArray( View view, CurveArray geometryCurveArray ) |
Visual Basic |
---|
Public Function NewDetailCurveArray ( _ view As View, _ geometryCurveArray As CurveArray _ ) As DetailCurveArray |
Visual C++ |
---|
public: DetailCurveArray^ NewDetailCurveArray( View^ view, CurveArray^ geometryCurveArray ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the detail curves are to be visible.
- geometryCurveArray
- Type: Autodesk.Revit.DB..::..CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.
Return Value
If successful an array of new detail curve elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in plane of the view |