Creates a consistent GUID for an IFC entity related to a Revit element.
A "related" sub-element is one that is unique for a given type of element, and can
therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.)
The index value 0 is reserved, as this would generate the GUID of the element itself.
A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is
expected that this list would be maintained up-to-date, instead of passing arbitrary values
into this function.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public static string CreateSubElementGUID(
Element pElement,
int subElementIndex
) |
Visual Basic |
---|
Public Shared Function CreateSubElementGUID ( _
pElement As Element, _
subElementIndex As Integer _
) As String |
Visual C++ |
---|
public:
static String^ CreateSubElementGUID(
Element^ pElement,
int subElementIndex
) |
Return Value
The guid string.
Exceptions
See Also