Removes all triggers associated with Updater with specified UpdaterId.
Does not unregister updater.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void RemoveAllTriggers( UpdaterId id ) |
Visual Basic |
---|
Public Shared Sub RemoveAllTriggers ( _ id As UpdaterId _ ) |
Visual C++ |
---|
public: static void RemoveAllTriggers( UpdaterId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of specified updater
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveAllTriggers called while executing an updater. |