An object that can be used to create new instances of Autodesk Revit API elements
within a project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Document Create { get; } |
Visual Basic |
---|
Public ReadOnly Property Create As Document Get |
Visual C++ |
---|
public: property Document^ Create { Document^ get (); } |
Field Value
This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is family document. |