Creates a solid by linearly extruding one or more closed coplanar curve loops.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public static Solid CreateExtrusionGeometry(
IList<CurveLoop> profileLoops,
XYZ extrusionDir,
double extrusionDist,
SolidOptions solidOptions
) |
Visual Basic |
---|
Public Shared Function CreateExtrusionGeometry ( _
profileLoops As IList(Of CurveLoop), _
extrusionDir As XYZ, _
extrusionDist As Double, _
solidOptions As SolidOptions _
) As Solid |
Visual C++ |
---|
public:
static Solid^ CreateExtrusionGeometry(
IList<CurveLoop^>^ profileLoops,
XYZ^ extrusionDir,
double extrusionDist,
SolidOptions^ solidOptions
) |
Parameters
- profileLoops
- Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The profile loops to be extruded. The loops must be closed, coplanar, and without intersections, self-intersections, or degeneracies. No loop may contain just one closed curve - split such loops into two or more curves beforehand.
No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions.
- extrusionDir
- Type: Autodesk.Revit.DB..::..XYZ
The direction in which to extrude the profile loops. This vector must be non-zero and transverse
(i.e., not parallel) to the plane of the profile loops. Its length is irrelevant; only its direction is used.
- extrusionDist
- Type: System..::..Double
The positive distance by which the loops are to be extruded in the direction of the input extrusionDir.
- solidOptions
- Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.
Return Value
The requested solid.
Exceptions
See Also