Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public void SetAttribute(
	string name,
	IFCData value
)
Visual Basic
Public Sub SetAttribute ( _
	name As String, _
	value As IFCData _
)
Visual C++
public:
void SetAttribute(
	String^ name, 
	IFCData^ value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: Autodesk.Revit.DB.IFC..::..IFCData
The value.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also