Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2021
Syntax
C# |
---|
public IList<UV> ComputeDerivatives(
double parameter,
bool normalized
) |
Visual Basic |
---|
Public Function ComputeDerivatives ( _
parameter As Double, _
normalized As Boolean _
) As IList(Of UV) |
Visual C++ |
---|
public:
IList<UV^>^ ComputeDerivatives(
double parameter,
bool normalized
) |
Parameters
- parameter
- Type: System..::..Double
The specified parameter along the curve.
- normalized
- Type: System..::..Boolean
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
The array containing three members: the first derivative (at index [0]), the second derivative (at index [1]) and the unit tangent vector (at index [2]).
Exceptions
See Also