Creates a new unplaced space on a given phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Space NewSpace( Phase phase ) |
Visual Basic |
---|
Public Function NewSpace ( _ phase As Phase _ ) As Space |
Visual C++ |
---|
public: Space^ NewSpace( Phase^ phase ) |
Parameters
- phase
- Type: Autodesk.Revit.DB..::..Phase
The phase in which the space is to exist.
Return Value
If successful the new space should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document. |