Gets the position of an existing vertex.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public XYZ GetVertex(
int index
) |
Visual Basic |
---|
Public Function GetVertex ( _
index As Integer _
) As XYZ |
Visual C++ |
---|
public:
XYZ^ GetVertex(
int index
) |
Parameters
- index
- Type: System..::..Int32
The index of the existing vertex. Should be between 0 and NumberOfVertices.
Return Value
The position of the vertex.
It is the offset point for the start and end vertex, not the connector point.
If the wire connects to one device, it may have offset; otherwise, the start and end vertex is same as the connector point.
Exceptions
See Also