Returns one or more properties for legacy (created in R2012 or before) Stairs.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public static void GetLegacyStairsProperties(
ExporterIFC exporterIFC,
Element pElement,
out int pNumRisers,
out int pNumTreads,
out double pRiserHeight,
out double pTreadLength,
out double pMinTreadLength,
out double pNosingLength,
out double pWaistThickness
) |
Visual Basic |
---|
Public Shared Sub GetLegacyStairsProperties ( _
exporterIFC As ExporterIFC, _
pElement As Element, _
<OutAttribute> ByRef pNumRisers As Integer, _
<OutAttribute> ByRef pNumTreads As Integer, _
<OutAttribute> ByRef pRiserHeight As Double, _
<OutAttribute> ByRef pTreadLength As Double, _
<OutAttribute> ByRef pMinTreadLength As Double, _
<OutAttribute> ByRef pNosingLength As Double, _
<OutAttribute> ByRef pWaistThickness As Double _
) |
Visual C++ |
---|
public:
static void GetLegacyStairsProperties(
ExporterIFC^ exporterIFC,
Element^ pElement,
[OutAttribute] int% pNumRisers,
[OutAttribute] int% pNumTreads,
[OutAttribute] double% pRiserHeight,
[OutAttribute] double% pTreadLength,
[OutAttribute] double% pMinTreadLength,
[OutAttribute] double% pNosingLength,
[OutAttribute] double% pWaistThickness
) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- pElement
- Type: Autodesk.Revit.DB..::..Element
the legacy stair.
- pNumRisers
- Type: System..::..Int32%
Number of Risers in the Stair.
- pNumTreads
- Type: System..::..Int32%
Number of Treads in the Stair.
- pRiserHeight
- Type: System..::..Double%
Riser Height of the risers in the Stair.
- pTreadLength
- Type: System..::..Double%
Tread length of the treads in the Stair.
- pMinTreadLength
- Type: System..::..Double%
Minimum Tread length of the treads in the Stair.
- pNosingLength
- Type: System..::..Double%
Nosing length of the treads in the Stair.
- pWaistThickness
- Type: System..::..Double%
Waist thickness of the flight of stair.
Exceptions
See Also