Extends the multistory stairs by connecting input levels.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void ConnectLevels( ISet<ElementId> levelIds ) |
Visual Basic |
---|
Public Sub ConnectLevels ( _ levelIds As ISet(Of ElementId) _ ) |
Visual C++ |
---|
public: void ConnectLevels( ISet<ElementId^>^ levelIds ) |
Parameters
- levelIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The level ids.
Remarks
The added stairs will be categorized into different groups based on level heights automatically. Stairs with the same level height are considered a group and can be edited together.
You cannot connect the levels between standard stairs top and bottom or already connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This multistory stairs cannot connect to one or more members of levelIds. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |