Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsCompatibleWith( FabricationService otherService ) |
Visual Basic |
---|
Public Function IsCompatibleWith ( _ otherService As FabricationService _ ) As Boolean |
Visual C++ |
---|
public: bool IsCompatibleWith( FabricationService^ otherService ) |
Parameters
- otherService
- Type: Autodesk.Revit.DB..::..FabricationService
Return Value
Returns true if the services are compatible.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |