Create a fixed segment direction constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeConstraintFixedSegmentDir( UV dir ) |
Visual Basic |
---|
Public Sub New ( _ dir As UV _ ) |
Visual C++ |
---|
public: RebarShapeConstraintFixedSegmentDir( UV^ dir ) |
Parameters
- dir
- Type: Autodesk.Revit.DB..::..UV
A fixed direction in UV-space.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | dir has zero length. |