Returns ElementIds for Category elements which are ignored (not taken into account) route calculation.
To enable ignoring of these categories, EnableIgnoredCategoryIds must be set to true.
If an ignored category has sub-categories, then the sub-categories will be ignored as well.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public ICollection<ElementId> GetIgnoredCategoryIds() |
Visual Basic |
---|
Public Function GetIgnoredCategoryIds As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ GetIgnoredCategoryIds() |