This property denotes a service as either public or private.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsPublic { get; set; } |
Visual Basic |
---|
Public Property IsPublic As Boolean Get Set |
Visual C++ |
---|
public: property bool IsPublic { bool get (); void set (bool value); } |
Remarks
A public service can be executed by anyone, while a private service can be execute only by the caller who registered it (the owner of the service, typically), or by someone who has access to the service's execution key.
Unless specified otherwise, all services are created as private by default.