The name of the class containing the implementation for the command.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public string ClassName { get; set; } |
Visual Basic |
---|
Public Property ClassName As String Get Set |
Visual C++ |
---|
public: property String^ ClassName { String^ get (); void set (String^ value); } |
Remarks
The class name which implements the interface IExternalCommand.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string. |