Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static ElementId GetWallConstructionType( Document ccda, ConceptualConstructionWallType typeEnum ) |
Visual Basic |
---|
Public Shared Function GetWallConstructionType ( _ ccda As Document, _ typeEnum As ConceptualConstructionWallType _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ GetWallConstructionType( Document^ ccda, ConceptualConstructionWallType typeEnum ) |
Parameters
- ccda
- Type: Autodesk.Revit.DB..::..Document
The Document.
- typeEnum
- Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionWallType
The ConceptualConstructionWallType to get the ConceptualConstructionType for.
Return Value
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWallType. -or- A value passed for an enumeration argument is not a member of that enumeration |