Indicates whether elements can be dragged immediately when they are selected.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool DragOnSelection { get; set; } |
Visual Basic |
---|
Public Property DragOnSelection As Boolean Get Set |
Visual C++ |
---|
public: property bool DragOnSelection { bool get (); void set (bool value); } |
Remarks
When this setting is false, the user must click once to select an element and then must
explicitly click again in order to drag the element. This option helps users avoid accidentally
moving elements. When this setting is true, the user can click on an element to select it
and drag the element immediately by holding down the mouse.