Provides access to user settings related to how selection will behave in Revit's UI.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class SelectionUIOptions : IDisposable |
Visual Basic |
---|
Public Class SelectionUIOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class SelectionUIOptions : IDisposable |
Remarks
The settings in this class define how selection will behave when the user is
selecting one or more elements in a graphical view. These settings do not affect programmatic selection behavior.
Some UI commands may override the user's settings while the command is active.
These settings are per user and will affect the selection behavior in all projects and families. The settings are not stored in the project.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..SelectionUIOptions
Autodesk.Revit.UI..::..SelectionUIOptions