Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces.
The output curve's direction will follow the parametric direction of the edge, not the topological
direction of the edge on the given face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public CurveUV GetCurveUV(
int index
) |
Visual Basic |
---|
Public Function GetCurveUV ( _
index As Integer _
) As CurveUV |
Visual C++ |
---|
public:
CurveUV^ GetCurveUV(
int index
) |
Parameters
- index
- Type: System..::..Int32
The index of the face (0 or 1).
Return Value
If successful, returns the calculated CurveUV,
nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.
Exceptions
See Also