Returns the triangle corresponding to the given index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public TriangleInShellComponent GetTriangle( int triangleIndex ) |
Visual Basic |
---|
Public Function GetTriangle ( _ triangleIndex As Integer _ ) As TriangleInShellComponent |
Visual C++ |
---|
public: TriangleInShellComponent^ GetTriangle( int triangleIndex ) |
Parameters
- triangleIndex
- Type: System..::..Int32
The index of the triangle (between 0 and TriangleCount-1, inclusive).
Return Value
The triangle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | triangleIndex is out of range. |