This class represents a triangulated boundary component of a solid or a
triangulated connected component of a shell.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public class TriangulatedShellComponent : IDisposable |
Visual Basic |
---|
Public Class TriangulatedShellComponent _ Implements IDisposable |
Visual C++ |
---|
public ref class TriangulatedShellComponent : IDisposable |
Remarks
The triangulation is "topologically connected" in the following sense:
if two triangles share an edge geometrically, then they share a single edge
topologically (i.e., they share two vertices defining the geometrically shared
edge).
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..TriangulatedShellComponent
Autodesk.Revit.DB..::..TriangulatedShellComponent