Fabrication double wall connector lock.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsDoubleWallConnectorLocked { get; set; } |
Visual Basic |
---|
Public Property IsDoubleWallConnectorLocked As Boolean Get Set |
Visual C++ |
---|
public: property bool IsDoubleWallConnectorLocked { bool get (); void set (bool value); } |
Remarks
If set this prevents the connector value being overridden by the fabrication specification.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | No double wall connector available. -or- When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item. |