Create a circumference constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeConstraintCircumference( ElementId paramId, RebarShapeArcReferenceType refType ) |
Visual Basic |
---|
Public Sub New ( _ paramId As ElementId, _ refType As RebarShapeArcReferenceType _ ) |
Visual C++ |
---|
public: RebarShapeConstraintCircumference( ElementId^ paramId, RebarShapeArcReferenceType refType ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
- refType
- Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the circumference.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |