Replaces all filters in this ScheduleDefinition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetFilters( IList<ScheduleFilter> filters ) |
Visual Basic |
---|
Public Sub SetFilters ( _ filters As IList(Of ScheduleFilter) _ ) |
Visual C++ |
---|
public: void SetFilters( IList<ScheduleFilter^>^ filters ) |
Parameters
- filters
- Type: System.Collections.Generic..::..IList<(Of <(<'ScheduleFilter>)>)>
The new list of filters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The resulting filter count would be greater than 8. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field and filter type cannot be used to filter this ScheduleDefinition. -or- A filter value is not valid for the field and filter type. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. |