Creates a CompoundStructure containing a single layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static CompoundStructure CreateSingleLayerCompoundStructure( MaterialFunctionAssignment layerFunction, double width, ElementId materialId ) |
Visual Basic |
---|
Public Shared Function CreateSingleLayerCompoundStructure ( _ layerFunction As MaterialFunctionAssignment, _ width As Double, _ materialId As ElementId _ ) As CompoundStructure |
Visual C++ |
---|
public: static CompoundStructure^ CreateSingleLayerCompoundStructure( MaterialFunctionAssignment layerFunction, double width, ElementId^ materialId ) |
Parameters
- layerFunction
- Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the single layer.
- width
- Type: System..::..Double
The width of the single layer.
- materialId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the material for the single layer.
Return Value
The newly created compound structure.
Remarks
It is not verified that materialId corresponds to a valid Material element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration |