Gets the raw parameter value at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2021

Syntax

C#
public double GetEndParameter(
	int index
)
Visual Basic
Public Function GetEndParameter ( _
	index As Integer _
) As Double
Visual C++
public:
double GetEndParameter(
	int index
)

Parameters

index
Type: System..::..Int32
Use 0 for the start parameter, 1 for the end parameter of the curve.

Return Value

The raw parameter value at the start or end of this curve.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException The given value for index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException This curve is unbound and does not have start and end points.

See Also