Checks whether a ForgeTypeId identifies a unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsUnit( ForgeTypeId unitTypeId ) |
Visual Basic |
---|
Public Shared Function IsUnit ( _ unitTypeId As ForgeTypeId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsUnit( ForgeTypeId^ unitTypeId ) |
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.
Return Value
True if the ForgeTypeId identifies a unit, false otherwise.
Remarks
A ForgeTypeId identifies a unit if it corresponds to a valid
DisplayUnitType value according to
UnitUtils.IsValidDisplayUnit(DisplayUnitType) and
UnitUtils.GetUnitTypeId(DisplayUnitType).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |