Checks whether a display unit is valid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsUnit(ForgeTypeId)` method instead.")] public static bool IsValidDisplayUnit( DisplayUnitType displayUnitEnum ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsUnit(ForgeTypeId)` method instead.")> _ Public Shared Function IsValidDisplayUnit ( _ displayUnitEnum As DisplayUnitType _ ) As Boolean |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsUnit(ForgeTypeId)` method instead.")] public: static bool IsValidDisplayUnit( DisplayUnitType displayUnitEnum ) |
Parameters
- displayUnitEnum
- Type: Autodesk.Revit.DB..::..DisplayUnitType
The display unit to check.
Return Value
True if the display unit is valid, false otherwise.
Remarks
A display unit is considered valid if it is an actual unit like
meters or feet. Obsolete values and the special values DUT_CUSTOM
and DUT_UNDEFINED are not considered valid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |